Contents

Planned Changes: Budget v4 API Soon Available

SAP Concur will release the Budget v4 API for partner and client use in a future release. Budget v4 provides the following features:

  • Fiscal Calendar: This API can GET, POST, and DELETE fiscal years and periods similar to the Fiscal Calendar UI in Budget Configuration.
  • Budget Category: This API can GET, POST, and DELETE budget categories, and GET all expense types of a budget category.
  • Budget Items: This API can GET, POST, and DELETE budget items including details such as period amounts, budget item tracking fields (cost objects), budget viewers, managers, and approvers.
  • Budget Tracking Field: This API can GET all budget tracking fields.
  • Budget Adjustment: This API can POST budget adjustments.
  • Global Availability: Budget v4 API is supported in all SAP Concur data centers.

Business Purpose / Client Benefit

This new Budget API enables clients and partners to integrate Budget with their ERP and HR systems to automate budget configuration and maintenance as well as importing external transactions not captured via SAP Concur through budget adjustments.

Configuration / Feature Activation

The Budget v4 API will be available to SAP Concur clients who have purchased Web Services, or partners who have contracted with SAP Concur.

Quick Expense v4 API Available

SAP Concur is releasing the Quick Expense v4 API for payment partner use.

Business Purpose / Client Benefit

This new version of the Quick Expense API supports the latest SAP Concur API authentication method, and provides several enhancements to the POST functionality.

Quick Expense v3 API Deprecation

SAP Concur is deprecating the Quick Expense v3 API due to security vulnerabilities identified. This API is being replaced by Quick Expense v4. Quick Expense v3 will be decommissioned in a future release. Please migrate to the Quick Expense v4 API.

Business Purpose / Client Benefit

The Quick Expense v3 API only supports the previous authentication method, and it provides access to some fields that are not necessary to expose. These issues are resolved with the new Quick Expense v4 API.